Windows,Androidとの格闘

最近、書いておかないと忘れるようになったので、Windowsのレジストリをいじったり、Androidのrootを取ったりするお話を書いていく(予定

BUFFALO NAS LS720D/N ( LS720 , LS720D ? )のHDD交換及び増設・増量(※保証対象外)について

Amazonで安かったので、BUFFALO NAS LS720D/N リンクステーション ( LinkStation ) を購入した。2TB版(RAID 1のため、初期設定のまま使うと、1TB)である。

起動させてみると(当然と言えば当然であるが)何も問題なく動いたので、早速HDD交換を実施してみた。入れ替えるだけでは、すんなり動いてくれなかったので、いつか未来のために、ここに書き残しておく。

 

※本ページ記載の内容は、メーカーの保証対象外のため、ここに記載されていることを鵜呑みにして製品を破損しても、メーカーの保証が受けられなくなっても一切関知しません。またファームウェアの更新等によって、将来この方法が出来なくなる可能性もあります。

※本ページ紹介の方法では、確実にデータが飛びます(フォーマットをかけるため)。そもそもデータを保存していない、他にもバックアップがあって消えても問題ない状態で実施してください。(消さない方法があるのかも知れませんが、面倒くさいので実施していません。)

 

購入したのは、

BUFFALO リンクステーション LS720D/N ネットワークHDD 2ベイ 2TB LS720D0202/N

 

入っていたHDDは、(2台とも)

SEAGATE BARRACUDA ST1000DM010

FW : CC46

 

交換したHDD(現在稼働中)は、

Western Digital WD60EZAZ

 

( 0_1 ) 当然のことながら初期不良がないことを確認するために、説明書に沿ってHDDを交換せずに起動する。この時点で起動しない、接続できない等の場合については、当方の関知するところではないため、メーカーや販売店に問い合わせてください。

( 0_2 ) [ 寄り道 ] 手順としては次 ( 1 ) へ。説明書どおり電源を切り、一気に2台ともHDDを交換して、起動してみたが、赤ランプで何もできない。eMMC内蔵らしいので期待したものの、ダメでした。

 

( 1 ) 電源を説明書どおりOFFにして、ランプが消えたことを確認し(念のため電源ケーブル・LANケーブルを抜き)、「1」(Disk 1)のHDDを先に交換します。なぜかは知りませんが、「2」を先に交換すると、次の手順に進めませんでした。物理的な交換方法は(見た目どおりですが心配な方は)、メーカー公式WebページのHTML説明書に「第9章 ドライブ故障時の交換手順」を参考にしてください。この時点で、メーカー推奨以外のドライブ(HDD)を使うため、保証が無くなります。静電気や端子の破損にご注意ください。

 

( 2 ) 起動して「Web設定画面を開く」とすると、(RAID 1の片方が交換されたことにより)「デグレードモード」で起動します。もしかすると、「確認」というポップアップが出てきて「RAIDアレイ1を構成する一部のドライブが認識できません。」と出るかも知れません。この場合は、一番下の選択肢「認識できないドライブを取り外してLinkStationを起動する」を選択して「実行」し、数字を入力する画面で確認番号を入力し「設定」すれば良いかと思います。

 

( 3 ) 設定画面の「ストレージ」の「ドライブ」を見に行くと、ドライブ1(交換した方)は「状態」が「破損」(新品のHDDだと「未フォーマット」?)扱いになりますが、「ドライブフォーマット」が可能です。「ドライブフォーマット」してください。「ドライブフォーマット」終了後しばらく待った方が良いです(10分くらい)。システム領域の修復・修正を実施しているみたいです。ちなみに、なぜかDisk 2から先に交換( ( 1 ) において、「2」から先に交換)すると、この「ドライブフォーマット」がクリック出来ない(グレーになってしまう)状態が発生しました。なお、ドライブ2も「状態」が「RAIDアレイ1 / 破損」と表示されているかも知れません、とりあえず放置します。(この表示は出ない(「状態」が「RAIDアレイ1 / 通常」と表示される)可能性もあります。)

 

( 4 ) 設定画面の「ストレージ」の「RAID」から、「RAIDアレイ1」をクリック、"左下"の「RAIDアレイの削除」を実施します。これも終了後、しばらく待ちましょう(10分くらい)。多分いらないと思いますが、「状態」が「破損」は気持ち悪いということであればドライブ2(交換していない方)についても「ストレージ」「ドライブ」から「ドライブフォーマット」してください。「ドライブフォーマット」後はしばらく待つ(10分くらい)のを忘れずに。

 

( 5 ) 電源をOFFにして、ランプが消えたのを確認して(電源ケーブル・LANケーブルを抜き)、「2」(Disk 2)を交換します。

 

( 6 ) 起動します。設定画面の「ストレージ」の「ドライブ」からドライブ2( ( 5 ) で交換した方、「状態」が「破損」又は「未フォーマット」)を「ドライブフォーマット」します。もし、ドライブ2を「ドライブフォーマット」できない(グレーになっていてクリックできない)場合は、電源をOFFにしてランプが消えた後、「1」(Disk 1)と「2」(Disk 2)の位置を入れ替えて起動して、ドライブ1(入れ替えたので、交換した方になる)を「ドライブフォーマット」してみてください。当方の環境では「1」と「2」を入れ替えると、グレーになっていた「ドライブフォーマット」がクリックできるようになりました。もし、ドライブ2(入れ替えたので、 ( 4 ) までで先に交換した方)の「状態」が「破損」の場合は「ドライブフォーマット」してください。この場合はなぜか可能だと思います。

 

( 7 ) 設定画面の「ダッシュボード」(TOPページ)に「新しい通知はありません。」と表示されれば完了です。「ストレージ」の「RAID」から新しいRAIDを設定できるかと思います。(当方、交換したHDDでRAID設定していないため、以後の説明はありません。)

 

 

その他:CPUがARMでDebianが動くかも知れない、ということでDebian化出来た暁には本ページを更新するかも知れません。最近、WindowsAndroidにはあまり触れていません(Armbianが楽しくて時間がない)。